POJ 1797 Silver Cow Party(Dijkstra)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
题意描述:
有n个农场,每个农场派出一头牛去参加x农场举办的派对,又给出了m条单向路径,然后让你求出,所有牛中参加完x农场举行的派对后再回到自己农场中所需要最大的距离是多少。 啰嗦了那么多其实就是求从自己的农场到x农场又回到自己农场的过程中,那个牛的路径最长。

#include<stdio.h>
#include<string.h>

int e[1010][1010];
int e1[1010][1010];
int main(void)
{
	int i,j,k,m,n,x,u;
	int dis[1010],book[1010],dis1[1010],book1[1010];
	int min,inf=99999999;
	int a,b,v;
	scanf("%d%d%d",&n,&m,&x);
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			if(i==j) e[i][j]=e1[i][j]=0;
				else e[i][j]=e1[i][j]=inf; 
						
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&v);
			e[a][b]=v
			e1[b][a]=v;
		 } 
		//求出x农场到各个农场的最短距离
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			dis[i]=e[x][i];	
		book[x]=1;
		for(i=1;i<n;i++)
		{
			min=inf;
			for(j=1;j<=n;j++)
			{
				if(book[j]==0&&dis[j]<min)
				{
					u=j;
					min=dis[j];
				}
			 } 
			 book[u]=1;
			 for(k=1;k<=n;k++)
			 {
			 	if(e[u][k]<inf)
			 	{
			 		if(dis[k]>dis[u]+e[u][k])
			 			dis[k]=dis[u]+e[u][k];
				 }
			 }
		 }
		//求出各个农场到x农场的最短距离
		memset(book1,0,sizeof(book1));
		for(i=1;i<=n;i++)
			dis1[i]=e1[x][i];	
		book1[x]=1;
		for(i=1;i<n;i++)
		{
			min=inf;
			for(j=1;j<=n;j++)
			{
				if(book1[j]==0&&dis1[j]<min)
				{
					u=j;
					min=dis1[j];
				}
			 } 
			 book1[u]=1;
			 for(k=1;k<=n;k++)
			 {
			 	if(e1[u][k]<inf)
			 	{
			 		if(dis1[k]>dis1[u]+e1[u][k])
			 			dis1[k]=dis1[u]+e1[u][k];
				 }
			 }
		 } 
		
		 int max=-1;
		 for(i=1;i<=n;i++)
		 {
		 	dis[i]+=dis1[i];
		 	if(max<dis[i])
			 	max=dis[i];
		 }
		printf("%d\n",max);
	return 0;
 } 
发布了53 篇原创文章 · 获赞 1 · 访问量 1361

猜你喜欢

转载自blog.csdn.net/fgets__/article/details/99194490