B1042 字符统计

1042 字符统计 (20 分)

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:

e 7
#include <iostream>
#include <cstdio>
#include <string>
using namespace std;

int hashtable[26] = {0};
int main()
{
	string str;
	getline(cin, str);
	int len = str.size();
	for(int i=0; i<len; i++){
		if(str[i] >= 'a' && str[i] <= 'z'){
			hashtable[str[i] - 'a']++;
		}else if(str[i] >= 'A' && str[i] <= 'Z'){
			hashtable[str[i] - 'A']++;
		}
	}
	int k = 0; 
	for(int i=0; i<26; i++){
		if(hashtable[i] > hashtable[k])
			k = i;
	}
	printf("%c %d\n", 'a' + k, hashtable[k]);
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/Highlight_Jin/article/details/88907575