ZOJ 3623 - Battle Ships(完全背包)(数据弱

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37868325/article/details/88557362

题意:

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5

思路:

完全背包的题,一开始感觉完全没有思路,dp想放时间,但是没有时间上限,所以也不会了,,,再就是不明白的是不知道如何处理顺序问题,要从前往后考虑,前面生产的状态也是想不到如何存

然后看了题解,感觉很有意思!对于每种战舰,考虑放到一开始的t[i]s生产,原【0,j-t[i]】s的状况直接全部拖后到【t[i],j】s,对塔造成的伤害完全不变,只需加上[t[i],j]秒内,一开始建出的战舰的伤害。(建造战舰的顺序肯定与t【i】与l【i】有关,所以若某个战舰建多艘,一定是连续建的,,)

不过这个题数据很弱,有些不正确的解答也能A

样例:

2 11
1 1
2 5
2 11
2 5
1 1

答案应该是4 4

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
#include<set>
#include<cmath>
#include<map>
#include<vector>
#include<iomanip>
using namespace std;
typedef long long ll;
const int maxn=100005;
int T,n,m,r,ans;
int dp[maxn];
char ch[105];
struct AA
{
    int t,l;
}pos[maxn];
int main()
{
    int j;
    while(~scanf("%d%d",&n,&m))
    {
        ans=0x3f3f3f3f;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d%d",&pos[i].t,&pos[i].l);
            for(j=0;j<=m;j++)
            {
                for(int i=1;i<=n;i++)
                {
                    dp[j+pos[i].t]=max(dp[j],dp[j]+pos[i].l*(j));
                    if(dp[j+pos[i].t]>=m)
                    {
                        ans=min(ans,j+pos[i].t);
                    }
                }
            }
            printf("%d\n",ans);
        }
}

/*



*/

猜你喜欢

转载自blog.csdn.net/qq_37868325/article/details/88557362
ZOJ