ZOJ3623船只背包

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases.
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1

1 1

2 10

1 1

2 5

3 100

1 10

3 20

10 100

Sample Output

2

5

4

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=4769

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=351;
int a[35],b[35],dp[N];
int main()
{
    int n,L;
    while(~scanf("%d%d",&n,&L))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a[i],&b[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=0;i<331;i++)
        {
            for(int j=0;j<n;j++)
            {
                dp[i+a[j]]=max(dp[i+a[j]],dp[i]+i*b[j]);
/*这个转移方程这么理解:在i+a[j]这么长的时间里,
能获得的最大伤害输出就是:max(
第1种:有一部分i个时间的伤害输出+另外一部分的a[j]个时间造个船,
a[j]这一部分的时间里,我啥都没干,就是造船;
第2种:我前a[j]时间造船,那么后i个时间
就输出伤害了(i*b[j]),剩下的i个时间,那就是dp[i]了嘛)*/
            }
        }
        for(int i=0;i<=331;i++)
        {
            if(dp[i]>=L)
            {
                cout<<i<<endl;break;
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/salmonwilliam/article/details/81515820