L2-003 月饼 (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zhaohaibo_/article/details/88827779

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:
每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50

题意:给出n种月饼的库存量和总价,在市场最大需求下,求最大利益
按每种月饼的单价(总价/库存量)降序排列


#include <iostream>
#include <algorithm>
using namespace std;

const int maxn = 1010;

struct Bing
{
    double val; // 单价
    double maxval; // 总价
    double maxw;   // 库存量
    bool operator<(const Bing &b) const
    {
        return val > b.val;
    }
} bing[maxn];

int n; 
double d; // n种饼, 市场最大需求d
double ans;
double totw, totval;

int main()
{
    cin >> n >> d;
    for (int i = 0; i < n; i++)
        cin >> bing[i].maxw;
    for (int i = 0; i < n; i++)
    {
        cin >> bing[i].maxval;
        // 单价 = 总价 / 库存量
        bing[i].val = bing[i].maxval / bing[i].maxw;
        totw += bing[i].maxw;
        totval += bing[i].maxval;
    }
    sort(bing, bing + n);

    if (totw <= d)
        ans = totval;
    else
    {
        int cur = 0; // 当前的饼编号
        while (1)
        {
            //  cur号饼全用
            if (bing[cur].maxw < d)
            {
                d -= bing[cur].maxw;
                ans += bing[cur].maxval;
            }
            else
            {
                // 从bing[cur]中取d
                ans += bing[cur].val * d;
                break;
            }
            cur++;
        }
    }

    printf("%.2f\n", ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zhaohaibo_/article/details/88827779
今日推荐