Maximum Product

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the
maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
you should consider 0 as the value of the maximum product.
Input
Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
is
an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
element in the sequence. There is a blank line after each test case. The input is terminated by end of
file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
M is the number of the test case, starting from 1, and P is the value of the maximum product. After
each test case you must print a blank line.
Sample Input
3
2 4 -3
5
2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.
Case #2: The maximum product is 20.
代码

#include<bits/stdc++.h>
using namespace std;
int arr[27];
int main()
{
    //freopen("F:\\1234.txt","r",stdin);
    //freopen("F:\\12345.txt","w",stdout);
    int n;
    int kase=0;
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
            cin>>arr[i];
        long long mx=0;
        for(int i=0;i<n;i++)
        {
            long long sum1=arr[i];
            mx=max(mx,sum1);
            for(int j=i+1;j<n;j++)
            {
                sum1*=arr[j];
                mx=max(mx,sum1);
            }
        }
        kase++;
        cout<<"Case #"<<kase<<": The maximum product is ";
        if(mx==0)
            cout<<0;
        else
            cout<<mx;
        cout<<"."<<endl<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43797508/article/details/88781989