PAT A1001 A+B Format (20)[A+B格式,字符串]

Calculate a + b a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification

Each input file contains one test case. Each case contains a pair of integers a and b where 1 0 6 a , b 1 0 6 -10^6 \leq a, b \leq 10^6 . The numbers are separated by a space.

Output Specification

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

思路1

逐位处理,注意和为负数和0的情况。

代码1

#include <iostream>
using namespace std;

int main()
{
    int a, b;
    scanf("%d%d", &a, &b);
    int sum = a + b;
    int num[10] = {0};
    int len = 0;
    if (sum < 0)
    {
        printf("-");
        sum = -sum;
    }
    while (sum)
    {
        num[len++] = sum % 10;
        sum /= 10;
    }
    for (int i = len - 1; i >= 0; i--)
    {
        printf("%d", num[i]);
        if (i > 0 && i % 3 == 0)
            printf(",");
    }
    printf("\n");
    return 0;
}

思路2

a+b 的和转为字符串s.除了第⼀位是负号的情况,只要当前位的下标i满足 (i + 1) % 3 == len % 3 并且 i不是后⼀位,就在逐位输出的时候在该位输出后的后面加上一个逗号。注意运算符优先级

代码2

#include <iostream>
using namespace std;

int main()
{
    int a, b;
    cin >> a >> b;
    string sum = to_string(a + b);
    int len = sum.size();
    for (int i = 0; i < len; i++)
    {
        cout << sum[i];
        if (sum[i] == '-')
            continue;
        if ((i + 1) % 3 == len % 3 && i + 1 != len)
            cout << ",";
    }
    return 0;
}

思路3

思路
1.计算 A + B 结果,并将其转换为字符串。
2.从后往前遍历字符串,每三个字符就加一个逗号(如果是最高数字位则不加 需要考虑负数情况)。

代码3

#include <iostream>
using namespace std;

int main()
{
    int a, b;
    cin >> a >> b;
    int c = a + b;
    string num = to_string(c);
    string res;

    for (int i = num.size() - 1, j = 0; i >= 0; i -- )
    {
        res = num[i] + res;  // 加到头前面
        ++ j;  // 当前处理了几位
        if (j % 3 == 0 && i && num[i - 1] != '-') // 第一个数字不加
            res = ',' + res;
    }

    cout << res << endl;
    return 0;
}

to_string()

  1. 转换后的字符串会保留负号(如果存在)
  2. double 会保留六位小数。
发布了166 篇原创文章 · 获赞 27 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/HdUIprince/article/details/105463768