M - Strategic Game

 

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

The input file contains several data sets in text format. Each data set represents a tree with the following description: 

the number of nodes 
the description of each node in the following format 
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier 
or 
node_identifier:(0) 

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data. 

For example for the tree: 

 

the solution is one soldier ( at the node 1). 

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table: 

Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Output

1
2

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2
#include<iostream>
#include<vector>
#include<cstring>

using namespace std;
vector<int>sons[10001];
int fa[10001];
int dp[10001][2];
int min(int a,int b)
{
	if(b<a)
	return b;
	else
	return a;
}
void dfs(int key)
{
	for(int i=0;i<sons[key].size();i++)
		dfs(sons[key][i]);
	for(int i=0;i<sons[key].size();i++)
	{
		dp[key][1]+=min(dp[sons[key][i]][1],dp[sons[key][i]][0]);//它开着,孩子最小的 
		dp[key][0]+=dp[sons[key][i]][1];//他不开是,孩子必须开着 
	}

}

int main()
{
	int n;
	while(cin>>n&&n!=EOF)
	{
		memset(dp,0,sizeof(dp));
		memset(fa,-1,sizeof(fa));
		memset(sons,0,sizeof(sons));
		while(n--)
		{
			int a,b,c;
			scanf("%d:(%d)",&a,&b);
			for(int i=0;i<=n;i++)
			{
				dp[i][1]=1;
			}
			for(int i=0;i<b;i++)
			{
				cin>>c;
				fa[c]=a;
				
				sons[a].push_back(c);
			}
		}
		int key=1;
		while(fa[key]!=-1)
		key=fa[key];
		dfs(key);
		cout<<min(dp[key][0],dp[key][1])<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SuBaiACCa/article/details/88410547