Strategic game POJ - 1463 (树型dp)

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 


  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

题意:有n座城市,给出城市与城市之间的关系,如:1:(2)2,3表示1号城市有2条关系,1与2,和1与3.现在,你需要在城市里面布置防卫,防卫可以保护这个城市以及与他有关系的城市,求最少需要布置的防卫的个数。

思路:如果一个城市布置了防卫,那么,与这个城市有关系的城市可布置防卫可不布置,如果这个城市没有布置防卫,那么,与他有关的城市必须布置防卫。我们可以用树型dp来解决这个问题。

#include "iostream"
#include "vector"
#include "cstdio"
#include "cstring"
using namespace std;
vector<int> G[1505];
bool vis[1505];
int dp[1505][2];//dp[i][j]表示i城市是否布置防卫
void dfs(int u)
{
    vis[u]=1;
    for(int i=0;i<G[u].size();i++){
        int v=G[u][i];
        if(!vis[v]){
            dfs(v);
            dp[u][1]+=min(dp[v][0],dp[v][1]);
            dp[u][0]+=dp[v][1];
        }
    }
}
int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(~scanf("%d",&n)){
        int u,t,v;
        char a;
        memset(vis,0, sizeof(vis));
        memset(dp,0xfffffff, sizeof(dp));
        for(int i=0;i<n;i++) G[i].clear();
        for(int i=0;i<n;i++) dp[i][1]=1,dp[i][0]=0;//初始划,如果这个城市布置防卫,那么是1,否则是0
        for(int i=0;i<n;i++){
            scanf("%d:(%d)",&u,&t);
            while(t--){
                scanf("%d",&v);
                G[u].push_back(v);
                G[v].push_back(u);
            }
        }
        dfs(0);
        printf("%d\n",min(dp[0][1],dp[0][0]));
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41874469/article/details/81197179