数据结构实验之图论四:迷宫探索(DFS深搜)

Problem Description

有一个地下迷宫,它的通道都是直的,而通道所有交叉点(包括通道的端点)上都有一盏灯和一个开关;请问如何从某个起点开始在迷宫中点亮所有的灯并回到起点?

Input

连续T组数据输入,每组数据第一行给出三个正整数,分别表示地下迷宫的结点数N(1 < N <= 1000)、边数M(M <= 3000)和起始结点编号S,随后M行对应M条边,每行给出一对正整数,表示一条边相关联的两个顶点的编号。

Output

若可以点亮所有结点的灯,则输出从S开始并以S结束的序列,序列中相邻的顶点一定有边,否则只输出部分点亮的灯的结点序列,最后输出0,表示此迷宫不是连通图。
访问顶点时约定以编号小的结点优先的次序访问,点亮所有可以点亮的灯后,以原路返回的方式回到起点。

Sample Input

1
6 8 1
1 2
2 3
3 4
4 5
5 6
6 4
3 6
1 5

Sample Output

1 2 3 4 5 6 5 4 3 2 1

Hint

Source

xam

#include<bits/stdc++.h>
using namespace std;
int n,m,s,sum,tot;
int vis[1010],b[1010];
int a[1010][1010];
void DFS(int s)
{
    vis[s]=1;
    sum++;
    b[++tot]=s;
    for(int i=1; i<=n; i++)
    {
        if(!vis[i]&&a[s][i])
        {
            DFS(i);
            b[++tot]=s;
        }
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        sum=tot=0;
        memset(vis,0,sizeof(vis));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        cin>>n>>m>>s;
        for(int i=1; i<=m; i++)
        {
            int u,v;
            cin>>u>>v;
            a[u][v]=a[v][u]=1;
        }
        DFS(s);
        for(int i=1; i<=tot-1; i++)
            cout<<b[i]<<" ";
        if(sum<n)
            cout<<b[tot]<<" "<<"0"<<endl;
        else
            cout<<b[tot]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43824158/article/details/88602796