“浪潮杯”山东省第九届ACM大学生程序设计竞赛(感谢山东财经大学) Anagram

Problem Description

Orz has two strings of the same length: A and B. Now she wants to transform A into an anagram of B (which means, a rearrangement of B) by changing some of its letters. The only operation the girl can make is to “increase” some (possibly none or all) characters in A. E.g., she can change an 'A' to a 'B', or a 'K' to an 'L'. She can increase any character any times. E.g., she can increment an 'A' three times to get a 'D'. The increment is cyclic: if she increases a 'Z', she gets an 'A' again.
For example, she can transform "ELLY" to "KRIS" character by character by shifting 'E' to 'K' (6 operations), 'L' to 'R' (again 6 operations), the second 'L' to 'I' (23 operations, going from 'Z' to 'A' on the 15-th operation), and finally 'Y' to 'S' (20 operations, again cyclically going from 'Z' to 'A' on the 2-nd operation). The total number of operations would be 6 + 6 + 23 + 20 = 55. However, to make "ELLY" an anagram of "KRIS" it would be better to change it to "IRSK" with only 29 operations.  You are given the strings A and B. Find the minimal number of operations needed to transform A into some other string X, such that X is an anagram of B.

Input

There will be multiple test cases. For each test case:
There is two strings A and B in one line.∣A∣=∣B∣≤50 |A| = |B| \leq 50∣A∣=∣B∣≤50. A and B will contain only uppercase letters from the English alphabet ('A'-'Z').

Output

For each test case, output the minimal number of operations.

Sample Input

ABCA BACA
ELLY KRIS
AAAA ZZZZ

Sample Output

0
29
100

思路:

先排序,因为此题说字母只能通过右移变换来实现变化,因此可以通过将b数组开成2倍,然后遍历即可。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <math.h>
using namespace std;
const int maxn=55;
char a[maxn];
char b[maxn<<1];
int main()
{
    while(scanf("%s%s",a,b)!=EOF)
    {
        int len=strlen(a);
        int ans=0x3f3f3f3f;
        sort(a,a+len);
        sort(b,b+len);
        for (int i=0;i<len;i++) b[i+len]=b[i];
        for (int i=0;i<=len;i++)
        {
            int tans=0;
            for (int j=0;j<len;j++)
            {
                if(a[j]<=b[i+j])
                {
                    tans+=b[i+j]-a[j];
                }
                else
                {
                    tans+='Z'-a[j]+b[i+j]-'A'+1;
                }
            }
            ans=min(ans,tans);
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/88561907