POJ Agri-Net 模板题

Agri-Net

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 71531   Accepted: 29637

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

USACO 102

题意:给出了城市的数目

又给出了邻接矩阵,输出使其全部连通的最小代价。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<math.h>
#include<algorithm>

using namespace std;
#define range 105
#define inf 0x3f3f3f3f



long map[range][range];
bool vis[range];
long dis[range];

void Prim(int n)
{
	int k=0;
	int pos=0;
	int sum=0;
	vis[pos]=true;
    int i,j;
    for(i=0;i<n;i++)
    {
    	dis[i]=map[pos][i];	
	}
	for(i=0;i<n-1;i++)
	{
		
		int min=inf;
		for(j=0;j<n;j++)
		{
			if(!vis[j]&&min>dis[j])
			{
				min=dis[j];
				pos=j;
			}
		}
		if(min!=0)
		{
		    sum+=min;
		}
		
		vis[pos]=true;
		for(j=0;j<n;j++)
		{
			if(!vis[j]&&dis[j]>map[pos][j])
			{
				dis[j]=map[pos][j];
			}	
		}
	}
    printf("%d\n",sum);
}
int main()
{
	int n,i,j;
	int a,b;
	while(~scanf("%d",&n))
	{
		memset(map,inf,sizeof(map));
		memset(vis,false,sizeof(vis));
		memset(dis,inf,sizeof(dis));
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				scanf("%d",&map[j][i]);
				map[i][j]=map[j][i];
			}
		}
		
		Prim(n);
	}
	return 0;
} 

基础题

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/88383248