最小生成树 之 kruskal 算法 Agri-Net POJ - 1258

原题:

     Agri-Net


    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
    The distance between any two farms will not exceed 100,000.


Input


    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem. 


Output


    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms. 
Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0

Sample Output

    28

题意:输入起始点到终止点 长度,求最短路径的和

解题思路:将权值从小到大排序,然后将选取的点加入并查集,避免重复选取

#include<cstdio>
#include<algorithm>
using namespace std;
struct node{
	int s,e,w;
}a[10005];
int fa[10005];
int m;
bool cmp(node a,node b){
	return a.w < b.w;
}
int get(int i){     // 获取父节点,并进行路径压缩
	if(fa[i] != i){
		fa[i] = get(fa[i]);
	}
	return fa[i];
}
void kruskal(){
	sort(a,a+m,cmp);
	int ans = 0;
	for(int i = 0;i < m;i++){
		int x = get(a[i].s);
		int y = get(a[i].e);
		if(x != y){        // 合并两个集合
			fa[x] = y;
			ans += a[i].w;   // 求最小权值和
		}
	}
	printf("%d\n",ans);
}
int main(){
	int n;
	while(scanf("%d",&n) != EOF){
		m = 1;
		for(int i = 1;i <= n;i++){
			fa[i] = i;
		}
		for(int j = 1;j <= n;j++){
			int x;
			for(int i = 1;i <= n;i++){
				scanf("%d",&x);
				a[m].s = j;
				a[m].e = i;
				a[m].w = x;
				m++;
			}
		}
		kruskal();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/error311/article/details/81904713
今日推荐