Agri-Net(最小生成树模板 prim)

题目描述:

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 

The distance between any two farms will not exceed 100,000. 

输入:

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

输出:

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

样例输入:

4
0 4 9 21
4 0 8 17
9 8 0 16

21 17 16 0

样例输出:

28


如何用最少的光纤将所有的农场连接起来,最小生成树,直接套模板即可。

#include<stdio.h>
#include<cstring>
#include<algorithm>
#define N 100+10
#define inf 0x3f3f3f3f
using namespace std;
int map[N][N],n;
int dis[N];
int logo[N];
int prim()
{
    int i,j,now;
    int sum=0;
    for(int i=0;i<n;i++)
    {
        dis[i]=inf;
        logo[i]=0;
    }
    for(int i=0;i<n;i++)
        dis[i]=map[0][i];
    dis[0]=0;
    logo[0]=1;
    for(int i=0;i<n-1;i++)
    {
        now=inf;
        int min=inf;
        for(int j=0;j<n;j++)
        {
            if(logo[j]==0&&dis[j]<min)
            {
                now=j;
                min=dis[j];
            }
        }
        if(now==inf)
            break;
        logo[now]=1;
        sum+=min;
        for(int j=0;j<n;j++)
        {
            if(logo[j]==0&&dis[j]>map[now][j])
                dis[j]=map[now][j];
        }
    }
        printf("%d\n",sum);
}
int main()
{
    int w;
    while(scanf("%d",&n)!=EOF)
    {
        memset(map,inf,sizeof(map));
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
            {
                scanf("%d",&w);
                map[i][j]=w;
            }
        prim();
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/qwerqwee12/article/details/79288385