POJ1258 Agri-Net——————最小生成树

Agri-Net

Language:Default
Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 68143 Accepted: 28244

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source


给的是点与点之间的邻接矩阵
求这些点的最小生成树


//#include<bits/stdc++.h>
#include<cstdio>
#include<vector>
#include<algorithm>

using namespace std;
const int MAXN=505;
int n,m,pre[MAXN];
struct Edge{
    int x,y,dis;
    Edge(){}
    Edge(int x1,int y1,int dis1)
    {
        x=x1; y=y1; dis=dis1;
    }
};
bool cmp(Edge a,Edge b)
{
    return a.dis<b.dis;
}
vector<Edge>d;
void init(){for(int i=1;i<=n;i++) pre[i]=i; }
int find(int x){return pre[x]==x?x:pre[x]=find(pre[x]); }
bool join(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
    {
        pre[x]=y;
        return true;
    }
    return false;
}


int main()
{

    while(~scanf("%d",&n))
    {
        d.clear();
        init();
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                int x;
                scanf("%d",&x);
                if(i==j)    continue;
                d.push_back(Edge(i,j,x));
            }
        sort(d.begin(),d.end(),cmp);
        int cnt=0,ans=0;
        for(int i=0;i<d.size();i++)
        {
            Edge e=d[i];
            if(join(e.x,e.y))
            {
                cnt++;
                ans+=e.dis;
            }
            if(cnt==n-1) break;
        }
        printf("%d\n",ans);
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81749936
今日推荐