February 29(模拟)

It is 2012, and it's a leap year. So there is a "February 29" in this year, which is called leap day. Interesting thing is the infant who will born in this February 29, will get his/her birthday again in 2016, which is another leap year. So February 29 only exists in leap years. Does leap year comes in every 4 years? Years that are divisible by 4 are leap years, but years that are divisible by 100 are not leap years, unless they are divisible by 400 in which case they are leap years.

In this problem, you will be given two different date. You have to find the number of leap days in between them.

Input

Input starts with an integer T (≤ 550), denoting the number of test cases.

Each of the test cases will have two lines. First line represents the first date and second line represents the second date. Note that, the second date will not represent a date which arrives earlier than the first date. The dates will be in this format - "month day, year", See sample input for exact format. You are guaranteed that dates will be valid and the year will be in between 2 * 103 to 2 * 109. For your convenience, the month list and the number of days per months are given below. You can assume that all the given dates will be a valid date.

Output

For each case, print the case number and the number of leap days in between two given dates (inclusive).

Sample Input

4

January 12, 2012

March 19, 2012

August 12, 2899

August 12, 2901

August 12, 2000

August 12, 2005

February 29, 2004

February 29, 2012

Sample Output

Case 1: 1

Case 2: 0

Case 3: 1

Case 4: 3

Note

The names of the months are {"January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November" and "December"}. And the numbers of days for the months are {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30 and 31} respectively in a non-leap year. In a leap year, number of days for February is 29 days; others are same as shown in previous line.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
int t;
using namespace std;
bool judge(ll y)
{
    if(y%4==0&&y%100!=0||y%400==0)
        return true;
    return false;
}
int main()
{
    scanf("%d",&t);
    int w=0;
    while(t--)
    {w++;
        char str1[50];
        char str2[50];
        ll d1,y1;
        ll d2,y2;
        scanf("%s%lld,%lld",str1,&d1,&y1);
        scanf("%s%lld,%lld",str2,&d2,&y2);
        ll ans1=y1/4+y1/400-y1/100;
        ll ans2=y2/4+y2/400-y2/100;
        ll ans=ans2-ans1;

        if(judge(y1))
        {
            if(str1[0]=='J'&&str1[1]=='a'||str1[0]=='F'&&d1<=29)
                ans++;

        }
        if(judge(y2))
        {
            if(str2[0]=='J'&&str2[1]=='a'||str2[0]=='F'&&d2<29)
                ans--;
        }
        printf("Case %d: %lld\n",w,ans);
    }
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/88749846
今日推荐