PAT 1059 Prime Factors(质因数分解)

 Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

 Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

 Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

代码

#include<cstdio>
#include<cmath>
#include<vector>
using namespace std;
typedef long long LL;
vector<int> factor;
vector<int> index;
void Divide(LL N)
{
    int Num,Temp=N;
    //质因数分解算法
    for(int i=2;i*i<=N;i++)
    {
        if(N%i==0)
        {
            factor.push_back(i);
            Num=0;
            while(N%i==0)
            {
                N/=i;
                Num+=1;
            }
            index.push_back(Num);
        }
    }
    if(N>1)
    {
        factor.push_back(N);
        index.push_back(1);
    }
    int Len=factor.size();
    printf("%d=",Temp);
    for(int i=0;i<Len;i++)
    {
        if(i==0)
        {
            if(index[i]!=1)
                printf("%d^%d",factor[i],index[i]);
            else
                printf("%d",factor[i]);
        }
        else
        {
            if(index[i]!=1)
                printf("*%d^%d",factor[i],index[i]);
            else
                printf("*%d",factor[i]);
        }
    }
    return ;
}
int main()
{
    LL N;
    scanf("%lld",&N);
    if(N==1)
        printf("1=1");
    else
        Divide(N);
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/84994340