南洋理工ACM 0002 括号配对问题

括号匹配问题
时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
现在,有一行括号序列,请你检查这行括号是否配对。
输入
第一行输入一个数N(0<N<=100),表示有N组测试数据。后面的N行输入多组输入数据,每组输入数据都是一个字符串S(S的长度小于10000,且S不是空串),测试数据组数少于5组。数据保证S中只含有"[", "]", "(", ")" 四种字符
输出
每组输入数据的输出占一行,如果该字符串中所含的括号是配对的,则输出Yes,如果不配对则输出No
样例输入
3
[(])
(])
([[]()])
样例输出
No
No
Yes

水题,考察栈的运用。可以用数组模拟栈,代码如下:

#include<iostream>
#include<cstdio>
#define MAX 10010
using namespace std;
int main()
{
	int t;
	cin >> t;
	getchar();
	while(t--) {
		int top = 0;
		char ch;
		char S[MAX];
		while(ch = getchar()) {
			if(ch == '\n')	break;
			else {
				if(ch ==')' && top > 0 && S[top - 1] == '(')	top--;
				else if (ch == ']' && top > 0 && S[top - 1] == '[')	top--;
				else S[top++] = ch;
			}	
		}
		if(top == 0)
			cout <<"Yes"<< endl;
		else
			cout <<"No"<< endl;
	}
}

猜你喜欢

转载自blog.csdn.net/xiao__hei__hei/article/details/80230976
今日推荐