简单dfs求联通快


The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2

这是一道dfs的简单题有利于初学者认识dfs

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>

using namespace std;

int n,m;
char s[110][110];
int xx[]={0,0,1,-1,1,-1,-1,1};
int yy[]={1,-1,0,0,1,-1,1,-1};
int x,y;
int vis[110][110];
void dfs(int x,int y)
{
	vis[x][y]=1;
	for(int i=0;i<8;i++){
		int dx=x+xx[i];
		int dy=y+yy[i];
		if(!vis[dx][dy]&&dx>=0&&dx<n&&dy>=0&&dy<m&&s[dx][dy]=='@'){
			dfs(dx,dy);
		}
	}
	return ;
}
int main()
{
	while(scanf("%d %d",&n,&m)){
		memset(vis,0,sizeof(vis));
		if(m==0)break;	
		for(int i=0;i<n;i++){
			scanf("%s",s[i]);
		}
		//getchar();
		//for(int i=0;i<n;i++){
			//getline(cin,s[i]);
		//}
		int ans=0;
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(!vis[i][j]&&s[i][j]=='@'){
					dfs(i,j);
					ans++;
				}
			}
		}
		printf("%d\n",ans);
	}
	
	return 0;
}
你的努力,也许有人会讥讽;你的执着,也许不会有人读懂。在别人眼里你也许是小丑,在自己心中你就是国王。好好努力相信自己,不比别人差。

猜你喜欢

转载自blog.csdn.net/ab1605014317/article/details/80284624