【POJ】1562Oil Deposits(dfs求联通块)

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21949   Accepted: 11430

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source

Mid-Central USA 1997

 题目大意:给出一个R*C的图,其中@代表油田,*则不是,问你其中的油田数目是多少,其中上下左右等八个方向相邻的油田均是一块,也就是联通块

思路:很简单的一道dfs的题目了,就是从每一个点查找他的八个方向,如果八个方向有油田,就把这个油田变成*,这样下一次就不会再次计算他,如果没有,就不需要做什么改变,这样在下面统计结果的时候只需要判断每一个点是否是有油田就行了,

代码:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#define maxn 1001
using namespace std;

int R,C;
int cnt;
char mp[maxn][maxn];

void dfs(int x,int y)
{
    if(x<0||x>=R||y<0||y>=C||mp[x][y]!='@')
        return ;

    mp[x][y]='*';
    dfs(x+1,y);
    dfs(x,y+1);
    dfs(x-1,y);
    dfs(x,y-1);
    dfs(x+1,y+1);
    dfs(x-1,y-1);
    dfs(x+1,y-1);
    dfs(x-1,y+1);
}

int main()
{
    while(scanf("%d%d",&R,&C)==2&&R)
    {
        cnt=0;
        for(int i=0;i<R;i++)
            scanf("%s",mp[i]);

        for(int i=0;i<R;i++)
            for(int j=0;j<C;j++)
                if(mp[i][j]=='@')
                    dfs(i,j),cnt++;
        printf("%d\n",cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/84350758