L1-023

L1-023 输出GPLT (20 分)
给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT…这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL
#include <iostream>
#include <string>

int main()
{
    std::string str;
    std::cin >> str;
    int len = str.size(), count_g(0), count_p(0), count_l(0), count_t(0);
    for (int i = 0; i < len; ++i)
    {
        if (str[i] == 'G' || str[i] == 'g')
            count_g++;
        else if (str[i] == 'P' || str[i] == 'p')
            count_p++;
        else if (str[i] == 'L' || str[i] == 'l')
            count_l++;
        else if (str[i] == 'T' || str[i] == 't')
            count_t++;
    }
    while (count_g || count_p || count_l || count_t)
    {
        if (count_g)
            std::cout << 'G', count_g--;
        if (count_p)
            std::cout << 'P', count_p--;
        if (count_l)
            std::cout << 'L', count_l--;
        if (count_t)
            std::cout << 'T', count_t--;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43231262/article/details/88623385