L1-023. 输出GPLT

 给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“GPLTGPLT....”这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL

代码:

#include<stdio.h>
char str[10010];
int main()
{
    int i,j,n=0,m=0,k=0,t=0;
    scanf("%s",str);
    for(i=0;str[i]!='\0';i++)
    {
        if(str[i]=='g'||str[i]=='G')
        {
           n++;
        }
        else if(str[i]=='p'||str[i]=='P')
        {
            m++;
        }
        else if(str[i]=='l'||str[i]=='L')
        {
            k++;
        }
        else if(str[i]=='t'||str[i]=='T')
        {
            t++;
        }
    }
    while(n||m||k||t)
    {
        if(n>0)
        {
            printf("G");
            n--;
        }
        if(m>0)
        {
            printf("P");
            m--;
        }
        if(k>0)
        {
            printf("L");
            k--;
        }
        if(t>0)
        {
            printf("T");
            t--;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guoqingshuang/article/details/80206181
今日推荐