L1-023. 输出GPLT (Java不超时)PAT团体程序设计天梯赛-练习集

版权声明:明明原创,相互学习,欢迎大佬:Q/23540008 https://blog.csdn.net/weixin_43461755/article/details/88616872

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“GPLTGPLT….”这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {

public static void main(String[] args) throws IOException {
    BufferedReader bReader = new BufferedReader(new InputStreamReader(System.in)); 
    char[]  str = bReader.readLine().toUpperCase().toCharArray(); 
    // 分别计数四个字母出现的次数
    int G_len = 0, P_len = 0, L_len = 0, T_len = 0;

    for (int i = 0; i < str.length; i++) {
    	
    	if (str[i]=='G') {
    		G_len++;
    	}else if (str[i]=='P') {
    		P_len++;
    	}else if (str[i]=='L') {
    		L_len++;
    	}else if (str[i]=='T') {
    		T_len++;
    	}
    }

    // 一直输出,直到所有字母个数都为 0
    while (G_len > 0 || P_len > 0 || L_len > 0 || T_len > 0) {
        if (G_len > 0) {
            System.out.print('G');
            G_len--;
        }

        if (P_len > 0) {
            System.out.print('P');
            P_len--;
        }

        if (L_len > 0) {
            System.out.print('L');
            L_len--;
        }

        if (T_len > 0) {
            System.out.print('T');
            T_len--;
        }
    }
}

}

猜你喜欢

转载自blog.csdn.net/weixin_43461755/article/details/88616872