杭电2017——字符统计C++版

Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。

Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output
6
9

#include<iostream>
using namespace std;
int main()
{
    int n,i;
    char a[100];
    cin>>n;
    while(n)
    {
        int c=0;
        cin>>a;
        for(i=0;a[i];i++)
        {
            if(a[i]>=48&&a[i]<=58)
                c++;
        }
        cout<<c<<endl;
        n--;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43289087/article/details/88623724