杭电2008--------数值统计C++版

Problem Description
统计给定的n个数中,负数、零和正数的个数。

Input
输入数据有多组,每组占一行,每行的第一个数是整数n(n<100),表示需要统计的数值的个数,然后是n个实数;如果n=0,则表示输入结束,该行不做处理。

Output
对于每组输入数据,输出一行a,b和c,分别表示给定的数据中负数、零和正数的个数。

Sample Input
6 0 1 2 3 -1 0
5 1 2 3 4 0.5
0

Sample Output
1 2 3
0 0 5

Author
lcy

Source
C语言程序设计练习(二)

#include<iostream>
using namespace std;
int main()
{
    double n,x;
    while(cin>>n)
    {
        if(n==0)break;
    double a=0,b=0,c=0,i=0;
    while(cin>>x)
    {
        i++;
        if(x<0)
        a++;
        else if(x==0)
        b++;
        else if(x>0)
        c++;
        if(i==n)break;
    }
    cout<<a<<" "<<b<<" "<<c<<endl;
    }
    return 0;
 } 

猜你喜欢

转载自blog.csdn.net/qq_43289087/article/details/88580786
今日推荐