HDU1028 Ignatius and the Princess III (母函数)

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

题意:一个数有几种合成方法。

#include<string.h>
#include<algorithm>
#include<stdio.h>
using namespace std;
long long A[1000],B[1000];
int main()
{
    for(long long i=0;i<=120;i++) B[i]=1;
    for(long long i=2;i<=120;i++)
    {
        for(long long v=0;v<=120;v++)
            A[v]=B[v];
        for(long long  k=1;k*i<=120;k++)
        {
            for(long long j=120;j>=0;j--)
            {
                B[j+i*k]+=A[j];
            }
        }
    }
    long long n;
    while(~scanf("%lld",&n))
    {
        printf("%lld\n",B[n]);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/84860852