hdu 1028 Ignatius and the Princess III 生成函数 模板题

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4 10 20

Sample Output

5 42 627

//生成函数篇简单题
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<cmath>
#include<deque>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

typedef long long ll;
const int inf = 0x3f3f3f3f;
const int M = 150;
ll num1[M],num2[M];
void init()
{
    num1[0]=1;
    for(int i=1;i<M;i++)
    {
        for(int j=0;j<M;j+=i)
        {
            for(int k=0;j+k<M;k++)
                num2[j+k]+=num1[k];
        }
        for(int j=0;j<M;j++)
        {
            num1[j]=num2[j];
            num2[j]=0;
        }
    }
}
int main()
{
    int n;
    init();
    while(~scanf("%d",&n))
    {
        printf("%lld\n",num1[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/liluoyu_1016/article/details/81805813