Ignatius and the Princess III(母函数)

Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24904 Accepted Submission(s): 17212

Problem Description

“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

Author

Ignatius.L

Recommend

We have carefully selected several similar problems for you: 1171 1085 1398 2152 1709
题目连接:这里写链接内容
水题。。。注意赋初值

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int N = 121;
long long int c1[N], c2[N];
void Init()
{
    int i, j, k;
    c1[0] = 1;
    for (i = 1; i <= N; i++)
    {
        for (j = 0; j <= N; j += i)
        {
            for (k = 0; k + j <= N; k++)
            {
                c2[k + j] += c1[k];
            }
        }
        for (j = 0; j <= N; j++)
        {
            c1[j] = c2[j];
            c2[j] = 0;
        }
    }
}
int main()
{
    int n;
    Init();
    while (cin >> n && n>0)
    {
        cout << c1[n] << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40883132/article/details/80866690
今日推荐