hdu-1754 I Hate It(线段树,单点更新,区间最值查询)

版权声明:本人大三在读,有错误烦请指正,共同进步- ( ゜- ゜)つロ 乾杯~点赞请按右上角,转载请标明出处: https://blog.csdn.net/hzyhfxt/article/details/85934424

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 107418    Accepted Submission(s): 40317


 

Problem Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

 

 

Input

本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

 

 

Output

对于每一次询问操作,在一行里面输出最高成绩。

 

 

Sample Input

 

5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5

 

 

Sample Output

 

5 6 5 9

Hint

Huge input,the C function scanf() will work better than cin

 

 

Author

linle

 

 

Source

2007省赛集训队练习赛(6)_linle专场 

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1698 1542 1394 2795 1540 

用了单点更新区间求和的模板,修改了下就可以用

【模板如下】


//注意:
//下标从1开始;
//使用方法:
//build(1, n);
//update(pos, val, 1, n); 更新树中下标为pos的叶子节点值增加val
//query(l, r, 1, n); 查询[l ,r]区间值之和

const int maxn = 5e4+5;
int a[maxn];
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int sum[maxn<<2];
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt=1)
{
    if (l==r)
    {
        sum[rt]=a[l];
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(int pos,int val,int l,int r,int rt=1)
{
    if (l==r)
    {
        sum[rt]+=val;
        return;
    }
    int m = ( l + r ) >> 1;
    if (pos<=m)
        update(pos, val, lson);
    else
        update(pos, val, rson);
    pushup(rt);
}
int query(int L,int R,int l,int r,int rt=1){
    if (L<=l&&r<=R)
        return sum[rt];
    int m=(l+r)>>1;
    int res=0;
    if (L<=m)
        res+=query(L, R, lson);
    if (R>m)        
        res+=query(L, R, rson);
    return res;
}

【通过代码】

注意:

定义操作字符时要大方一点...不要只定义一

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <map>
#include <list>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn = 2e5+5;
int a[maxn];

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
int getmax[maxn<<2];
void pushup(int rt)
{
    getmax[rt]=max(getmax[rt<<1],getmax[rt<<1|1]);//修改为取max
}
void build(int l,int r,int rt=1)
{
    if (l==r)
    {
        getmax[rt]=a[l];
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);//由底向上求最大值
}
void update(int pos,int val,int l,int r,int rt=1)
{
    if (l==r)
    {
        getmax[rt]=val;//修改为 更新值
        return;
    }
    int m = ( l + r ) >> 1;
    if (pos<=m)
        update(pos, val, lson);
    else
        update(pos, val, rson);
    pushup(rt);
}
int query(int L,int R,int l,int r,int rt=1){
    if (L<=l&&r<=R)
        return getmax[rt];
    int m=(l+r)>>1;
    int res=-1;
    if (L<=m)
        res=max(res,query(L, R, lson));//修改
    if (R>m)
        res=max(res,query(L, R, rson));
    return res;
}
int main()
{
    int n,m,x,y;
    char op[5];//第一次自定义了一个字符wa了...
    while(scanf("%d%d",&n,&m) != EOF)//第二次没有多组输入wa了...
    {
        for(int i=1;i<= n;i++)
            scanf("%d",&a[i]);
        build(1,n);
        while(m--)
        {
            scanf("%s%d%d",op,&x,&y);
            if(op[0] == 'U')
                update(x, y, 1, n);
            if(op[0] == 'Q')
                printf("%d\n",query(x, y, 1, n));
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/85934424