PAT 甲级 1129 Recommendation System

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/a845717607/article/details/87910406

1129 Recommendation System (25 point(s))

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

经验总结:

emmm  这一题,不能利用sort和vector组合进行排序然后输出,这样会超时,这里使用set集合来实现,map应该也可以,不过这里键值必须作为整体,所以set比较合适,每次更新数据,都要先将原来的对应商品的数据删除,更新商品访问次数,然后再将其插入,最后注意控制一下输出商品的个数就行啦~

AC代码

#include <cstdio>
#include <set>
using namespace std;
const int maxn=50010;
int n,k,t,num[maxn]={0};
struct node
{
	int key,value;
	bool operator <(const node &a)const
	{
		if(a.value!=value)
			return value>a.value;
		return key<a.key;
	}
	node(int a,int b):key(a),value(b){}
};
int main()
{
	scanf("%d%d",&n,&k);
	set<node> s;
	scanf("%d",&t);
	++num[t];
	s.insert(node(t,num[t]));
	for(int i=1;i<n;++i)
	{
		scanf("%d",&t);
		printf("%d:",t);
		int x=0;
		for(set<node>::iterator it=s.begin();it!=s.end();++it)
		{
			if(x<k)
				printf(" %d",it->key);
			else
				break;
			++x;
		}
		printf("\n");
		set<node>::iterator it=s.find(node(t,num[t]));
		if(it!=s.end())
			s.erase(it);
		++num[t];
		s.insert(node(t,num[t]));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/87910406