1129 Recommendation System(25 分)(C++)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

思路:首先每个元素都是唯一的,首先先要有个容器存储出现了的元素,这里想到set,还要存储这些元素的出现次数,自然的想到结构体,要是可以set插入时候自动排序就最好了。好了重载set即可。

知识点:set重载:

针对结构体重载,有以下的格式:

struct info{
    int id,rank;
    bool operator<(const info &a)const{
        return a.rank!=rank?a.rank<b.rank:a.id<b.id;
    }
}

本题代码则如下:

#include <iostream>
#include <cstdio>
#include <set>
#include <vector>
using namespace std;
struct node{
    int cnt,value;
    bool operator<(const node &a)const{
        return (cnt!=a.cnt)?cnt>a.cnt:value<a.value;
    }
};
int n,m;
int main(){
    set<node>s;
    scanf("%d %d",&n,&m);
    std::vector<int> v(n+1,0);
    for(int i=0;i<n;i++){
        node temp;
        scanf("%d",&temp.value);
        if(i!=0){
            printf("%d:",temp.value);
            int num=0;
            for(auto it=s.begin();num<m&&it!=s.end();it++){
                printf(" %d",it->value);
                num++;
            }
            printf("\n");
        }
        temp.cnt=v[temp.value];
        if(s.find(temp)!=s.end())
            s.erase(temp);
        temp.cnt++;
        v[temp.value]++;
        s.insert(temp); 
    }
    system("pause");
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/81942146