1129 Recommendation System (25 分)

1129 Recommendation System (25 分)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

长知识了 set还能这么用  转载来自:https://blog.csdn.net/ysq96/article/details/81569955


代码:

#include<bits/stdc++.h>
using namespace std;
struct node
{
	int num,cnt;
	node(int a, int b){
		num = a;
		cnt = b;
	}
	bool operator <(const node &a)const {
		return cnt != a.cnt ? cnt > a.cnt : num < a.num;
	}
};
set<node>s;
int main()
{
	int n, k;
	scanf("%d%d",&n ,&k);
	int tt[50005] = {0};
	for(int i = 0; i < n; i ++)
	{
		int num;
		scanf("%d",&num);
		if(i)
		{
			printf("%d:",num);
			int ans = 0;	
			set<node>::iterator it = s.begin();
			for(it; it != s.end() && ans < k; it++)
			{
				printf(" %d",it->num);
				ans++;
			}
			putchar('\n');
		}	
		set<node>::iterator it = s.find(node(num,tt[num])); 
		if(it != s.end())
			s.erase(it);
		tt[num]++;
		s.insert(node(num,tt[num]));
	}	
	return 0;	
}

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/84842139