1089 Insert or Merge (25 分)(C++)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

解题思路:首先判断是归并排序还是插入排序,从理解的角度,插入排序的判断更容易理解,所以直接判断是否是插入排序,然后再针对归并排序和插入排序分别处理。

判断:插入排序的特点,n个数排序,则需要n轮,假设现在在第x轮,有前x个数有序,后n - x数与原序列一致。

插入排序的处理:在判断的时候已经得到了x个数有序,只要另前x+1个数有序即可

归并排序的处理:关键在于求步长,根据归并排序的特点,有先两个一组排序,再四个一组排序......所以不妨对原序列按对应步长一一排序,找到与排序后的序列一致的步长即可,然后再用步长为该步长的2倍进行排序。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main(){
    bool flag = true;
    int n,i = 0,temp;
    cin>>n;
    std::vector<int> initial(n), partsorted(n);
    for(i = 0; i < n; i++)
        scanf("%d",&initial[i]);
    for(i = 0; i < n; i++)
        scanf("%d",&partsorted[i]);
    i = 1;
    while(partsorted[i-1] <= partsorted[i])
        i++;
    temp = i;
    while(i < n && partsorted[i] == initial[i])
        i++;
    if(i < n) 
        flag = false;
    if(flag == true){
        sort(partsorted.begin(), partsorted.begin()+temp+1);
        printf("Insertion Sort\n%d",partsorted[0]);
    }
    else{
    	bool tempflag = false;
    	temp = 2;
    	while(! tempflag){
    		for(i = 0; i < n; i += temp)
    			sort(initial.begin()+i,initial.begin()+min(n,i+temp));
    		tempflag = (partsorted == initial);
    		temp *= 2;
		}
        for(i = 0; i < n; i += temp)
    		sort(partsorted.begin()+i,partsorted.begin()+min(n,i+temp));
        printf("Merge Sort\n%d",partsorted[0]);   
    }
    for(i = 1; i < n; i++)
        printf(" %d",partsorted[i]);
}

猜你喜欢

转载自blog.csdn.net/qq_41562704/article/details/87969260