1089 Insert or Merge (25 分)(插入排序,归并排序)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10

3 1 2 8 7 5 9 4 6 0

扫描二维码关注公众号,回复: 4781952 查看本文章

1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort

1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10

3 1 2 8 7 5 9 4 0 6

1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort

1 2 3 8 4 5 7 9 0 6

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <stack>
#include <queue>
#include <cmath>
using namespace std;
int main()
{
    int n;
    cin>>n;
    int a[n],b[n];
    for(int i=0;i<n;i++) cin>>a[i];
    for(int i=0;i<n;i++) cin>>b[i];
    int i,j;
    for(i=0;b[i]<=b[i+1]&&i<n-1;i++);   //i,j用来判断是不是插入排序,秒懂的
    for(j=i+1;a[j]==b[j]&&j<n;j++);
    if(j==n){
        cout<<"Insertion Sort\n";
        sort(a,a+i+2);
    }else{
        cout<<"Merge Sort\n";
        int flag=1,k=1;
        while(flag){
            flag=0;
            for(i=0;i<n;i++)
                if(a[i]!=b[i]) flag=1;
            k*=2;
            for(i=0;i<n/k;i++)
                sort(a+i*k,a+(i+1)*k);
            sort(a+n/k*k,a+n);  //剩余那些元素的排序
        }
    }
    for(i=0;i<n;i++){
        if(!i) cout<<a[i];
        else cout<<" "<<a[i];
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42068614/article/details/85763443
今日推荐