PAT A 1089 Insert or Merge

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

#include<cstdio>
#include<algorithm>
using namespace std;

int n;
int origin[110], temp[110], change[110];

bool isSame(int a[], int b[]) {
    for (int i = 0; i < n; i++) {
        if (a[i] != b[i]) return false;
    }
    return true;
}

void print(int a[]) {
    for (int i = 0; i < n; i++) {
        printf("%d", a[i]);
        if (i != n - 1) printf(" ");
    }
}

bool insertSort() {
    bool flag = false;
    for (int i = 1; i < n; i++) {
        if (i!=1 && isSame(temp, change)) flag = true;//坑点,就是算法笔记提到的第二点,不然会有双解
        int j = i;
        int Temp = temp[i];
        while (j > 0 && temp[j-1] > Temp) {
            temp[j] = temp[j - 1];
            j--;
        }
        temp[j] = Temp;
        if (flag == true) return true;
    }
    return false;
}

bool mergeSort() {
    bool flag = false;
    for (int step = 2; step / 2 <= n; step *= 2) {//归并排序的非递归写法
        if (step!=2 && isSame(temp, change)) flag = true;
        for (int i = 0; i < n; i += step) {
            sort(temp + i, temp + min(i + step, n));//注意,归并排序最后一组,数据个数可能少一些,所以这样写
        }
        if (flag == true) return true;
    }
    return false;
}

int main() {
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &origin[i]);
        temp[i] = origin[i];
    }
    for (int i = 0; i < n; i++) {
        scanf("%d", &change[i]);
    }

    if (insertSort()) {
        printf("Insertion Sort\n");
        print(temp);
    }

    for (int i = 0; i < n; i++) {//还原
        temp[i] = origin[i];
    }

    if (mergeSort()) {
        printf("Merge Sort\n");
        print(temp);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/81047374
今日推荐