1089 Insert or Merge(25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

解题思路:

本题要完全模拟插入排序和归并排序(merge也可以通过sort()模拟,只要不超时就行)。
本题一个要点是,判断序列是某种算法的中间序列之后,还要再输出此方法下一轮的序列。
可以在排序方法中添加一个标志flag,每一轮前判断两个序列是否相等,相等则flag=true;而每一轮操作后,再判断标志flag是否=true。
本题就是烦而不难,如果对两种排序算法记得不牢的话,解题就会很费时间。

AC代码

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 110;
int a1[maxn], a2[maxn], a3[maxn];
int n;
bool isSame(int a[], int b[]) {
    for (int i = 0; i < n; i++)
        if (a[i] != b[i]) return false;
    return true;
}
void output(int a[]) {
    printf("%d", a[0]);
    for (int i = 1; i < n; i++)
        printf(" %d", a[i]);
    printf("\n");
}
void merge1(int a[], int l1, int r1, int l2, int r2) {
    int i = l1, j = l2;
    int temp[maxn], index = 0;
    while (i <= r1 && j <= r2)
    {
        if (a[i] <= a[j])
            temp[index++] = a[i++];
        else
            temp[index++] = a[j++];
    }
    while (i <= r1) temp[index++] = a[i++];
    while (j <= r2) temp[index++] = a[j++];
    for (i = 0; i < index; i++)
        a[l1 + i] = temp[i];
}
void mergeSort() {
    int step, mid, i;
    bool flag = false;
    for (step = 2; step / 2 <= n; step *= 2)
    {
        if (step != 2 && isSame(a1, a3))
            flag = true;
        for (i = 0; i < n; i += step)
        {
            mid = i + step / 2 - 1;
            if (mid + 1 < n)
                merge1(a1, i, mid, mid + 1, min(i + step - 1, n - 1));
        }
        if (flag)
        {
            output(a1);
            return;
        }
    }
}
bool insertSort() {
    int i, j, temp;
    bool flag = false;
    for (i = 1; i < n; i++)
    {
        if (i != 1 && isSame(a2, a3))
            flag = true;
        j = i;
        temp = a2[j];
        while (j > 0 && a2[j - 1] > temp)
        {
            a2[j] = a2[j - 1];
            j--;
        }
        a2[j] = temp;
        if (flag)
            return true;
    }
    return false;
}

int main() {
    int i;
    scanf("%d", &n);
    for (i = 0; i < n; i++)
    {
        scanf("%d", &a1[i]);
        a2[i] = a1[i];
    }
    for (i = 0; i < n; i++)
        scanf("%d", &a3[i]);

    if (insertSort())
    {
        printf("Insertion Sort\n");
        output(a2);
    }
    else
    {
        printf("Merge Sort\n");
        mergeSort();
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/fried123123/article/details/81432096