并查集 逆向思考

In order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers ab (0 <= ab <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

"query a" - star a wanted to know which star it should turn to for help

扫描二维码关注公众号,回复: 5299968 查看本文章

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1

这里可用这样想,我们先把询问储存起来,从最后一个询问开始,当遇到d时,我们把这两个点连接起来,那么就能正常回答前面的询问了。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;
const int MAXN=10010;
int F[MAXN];
int p[MAXN];
int val[MAXN];//最大值的下标
int num[MAXN];//最大值
int finds(int x)
{
    if(F[x]==-1)
        return x;
    return F[x]=finds(F[x]);
}
void init(int u,int v)//这里特殊处理一下
{
    int t1=finds(u),t2=finds(v);
    if(t1!=t2)
    {
        F[t1]=t2;//父节点
        if(num[t1]>num[t2])
        {
            num[t2]=num[t1];
            val[t2]=val[t1];//
        }
        else if(num[t1]==num[t2] && val[t2]>val[t1])
            val[t2]=val[t1];//第二个节点的编号也要大
    }
}
map<int,int>mp[MAXN];
struct Edge
{
    int u,v;
} edge[20010];
bool used[20010];
struct Node
{
    int op;
    int u,v;
} node[50010];
int ans[50010];
char str[20];
int main()
{
    int n;
    int Q;
    int m;
    int u,v;
    bool first=true;
    while(scanf("%d",&n)==1)
    {
        if(first)
            first=false;
        else
            printf("\n");
        memset(F,-1,sizeof(F));
        for(int i=0; i<n; i++)
        {
            scanf("%d",&p[i]);//
            val[i]=i;//节点号
            num[i]=p[i];//价值
            mp[i].clear();//所
        }

        scanf("%d",&m);//m组数据
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&u,&v);
            if(u>v)
                swap(u,v);//保证v大
            mp[u][v]=i;//证明是第i个节点
            edge[i].u=u;
            edge[i].v=v;//证明这两个节点相连
            used[i]=false;//
        }
        scanf("%d",&Q);//
        for(int i=0; i<Q; i++)
        {
            scanf("%s",&str);//
            if(str[0]=='q')
            {
                node[i].op=0;//
                scanf("%d",&node[i].u);//
            }
            else
            {
                node[i].op=1;
                scanf("%d%d",&u,&v);//
                if(u>v)
                    swap(u,v);
                node[i].u=u;
                node[i].v=v;//nide存储需要破坏的
                int tmp=mp[u][v];
                used[tmp]=true;//看是上边连接的第几个点
            }
        }
        for(int i=0; i<m; i++)
            if(!used[i])
            {
                init(edge[i].u,edge[i].v);//没有被破坏的
            }
        int cnt=0;
        for(int i=Q-1; i>=0; i--)
        {
            if(node[i].op==0)//逆向看
            {
                u=node[i].u;
                int t1=finds(u);
                if(num[t1]>p[u])
                    ans[cnt++]=val[t1];
                else
                    ans[cnt++]=-1;
            }
            else
            {
                init(node[i].u,node[i].v);//这样就能正确回答前面的询问了
            }
        }
        for(int i=cnt-1; i>=0; i--)
            printf("%d\n",ans[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/87821865