FZU - 2271 X 【floyd】

Problem 2271 X

Accept: 290    Submit: 1158
Time Limit: 1500 mSec    Memory Limit : 32768 KB

 Problem Description

X is a fully prosperous country, especially known for its complicated transportation networks. But recently, for the sake of better controlling by the government, the president Fat Brother thinks it’s time to close some roads in order to make the transportation system more effective.

Country X has N cities, the cities are connected by some undirected roads and it’s possible to travel from one city to any other city by these roads. Now the president Fat Brother wants to know that how many roads can be closed at most such that the distance between any two cities in country X does not change. Note that the distance between city A and city B is the minimum total length of the roads you need to travel from A to B.

 Input

The first line of the date is an integer T (1 <= T <= 50), which is the number of the text cases.

Then T cases follow, each case starts with two numbers N, M (1 <= N <= 100, 1 <= M <= 40000) which describe the number of the cities and the number of the roads in country X. Each case goes with M lines, each line consists of three integers x, y, s (1 <= x, y <= N, 1 <= s <= 10, x is not equal to y), which means that there is a road between city x and city y and the length of it is s. Note that there may be more than one roads between two cities.

 Output

For each case, output the case number first, then output the number of the roads that could be closed. This number should be as large as possible.

See the sample input and output for more details.

 Sample Input

22 31 2 11 2 11 2 23 31 2 12 3 11 3 1

 Sample Output

Case 1: 2Case 2: 0

 Source

第七届福建省大学生程序设计竞赛-重现赛(感谢承办方闽江学院)

题意:

求最多删去多少边,任意两点间的最短路不变。

思路:

可以用floyd,边更新边删除。输入时先删除多余的边,用一个use数组标记两点之间是否有一条边。更新时,如果存在一条路径小于等于这条边,更新最短路径,并且这条边没有被删除,就可以删除这条边。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<iostream>
using namespace std;
#define inf 0x3f3f3f3f
int n,m,G[105][105];
bool vis[105][105],use[105][105];
int main()
{
    int cas;
    scanf("%d",&cas);
    for(int tt=1;tt<=cas;tt++)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i==j) G[i][j]=0;
                else G[i][j]=inf;
        int ans=0;
        memset(use,0,sizeof use);
        for(int i=0;i<m;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            G[u][v]=G[v][u]=min(G[u][v],w);
            if(use[u][v]) ans++;
            use[u][v]=use[v][u]=1;
        }
        memset(vis,0,sizeof vis);
        for(int k=1;k<=n;k++)
        {
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(G[i][j]>=G[i][k]+G[k][j] && i!=j && i!=k && k!=j)
                    {
                        G[i][j]=G[i][k]+G[k][j];
                        if(use[i][j] && !vis[i][j])
                        {
                            vis[i][j]=vis[j][i]=1;
                            ans++;
                        }
                    }
                }
            }
        }
        printf("Case %d: %d\n",tt,ans);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/u013852115/article/details/80085490