ZOJ1099 POJ2271 HTML【文本】

HTML
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8060 Accepted: 2612

Description

If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags)
which is a linebreak and


which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.

Input

The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.

Output

You should display the the resulting text using this rules:
If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
If you read a <br> in the input, start a new line.
If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again).
The last line is ended by a newline character.

Sample Input
Hallo, dies ist eine
ziemlich lange Zeile, die in Html
aber nicht umgebrochen wird.
<br>
Zwei <br> <br> produzieren zwei Newlines.
Es gibt auch noch das tag <hr> was einen Trenner darstellt.
Zwei <hr> <hr> produzieren zwei Horizontal Rulers.
Achtung mehrere Leerzeichen irritieren
Html genauso wenig wie
mehrere Leerzeilen.

Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen
wird.
Zwei
produzieren zwei Newlines. Es gibt auch noch das tag
--------------------------------------------------------------------------------
was einen Trenner darstellt. Zwei
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html
genauso wenig wie mehrere Leerzeilen.

Source

Ulm Local 1999

问题链接ZOJ1099 POJ2271 HTML
问题简述:(略)
问题分析
    文本处理题,占个位置,暂时不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* ZOJ1099 POJ2271 HTML */

#include <stdio.h>
#include <string.h>

#define N 81
char s[N];

int main(void)
{
    int cnt = 0, i;
    while(scanf("%s", s) != EOF) {
        if(strcmp(s, "<hr>") == 0) {        /* 处理<hr> */
            if(cnt)                                     /* 不是新行则换行 */
                printf("\n");
            for(i = 1; i <= 80; i++)
                printf("-");
            printf("\n");
            cnt = 0;
        } else if(strcmp(s, "<br>") == 0) {
            printf("\n");
            cnt = 0;
        } else {
            if(cnt + strlen(s) + (cnt ? 1 : 0) > 80) {
                printf("\n%s", s);
                cnt = strlen(s);
            } else {
                if(cnt) printf(" ");
                printf("%s", s);
                cnt += strlen(s) + 1;
            }
        }
    }
    printf("\n");

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10356518.html