FZU-2271——X

Problem 2271 X

Accept: 394    Submit: 1635
Time Limit: 1500 mSec    Memory Limit : 32768 KB

 Problem Description

X is a fully prosperous country, especially known for its complicated transportation networks. But recently, for the sake of better controlling by the government, the president Fat Brother thinks it’s time to close some roads in order to make the transportation system more effective.

Country X has N cities, the cities are connected by some undirected roads and it’s possible to travel from one city to any other city by these roads. Now the president Fat Brother wants to know that how many roads can be closed at most such that the distance between any two cities in country X does not change. Note that the distance between city A and city B is the minimum total length of the roads you need to travel from A to B.

 Input

The first line of the date is an integer T (1 <= T <= 50), which is the number of the text cases.

Then T cases follow, each case starts with two numbers N, M (1 <= N <= 100, 1 <= M <= 40000) which describe the number of the cities and the number of the roads in country X. Each case goes with M lines, each line consists of three integers x, y, s (1 <= x, y <= N, 1 <= s <= 10, x is not equal to y), which means that there is a road between city x and city y and the length of it is s. Note that there may be more than one roads between two cities.

 Output

For each case, output the case number first, then output the number of the roads that could be closed. This number should be as large as possible.

See the sample input and output for more details.

 Sample Input

2

2 3

1 2 1

1 2 1

1 2 2

3 3

1 2 1

2 3 1

1 3 1

 Sample Output

Case 1: 2

Case 2: 0

 Source

第七届福建省大学生程序设计竞赛-重现赛(感谢承办方闽江学院)

题目大意:给出一些路,问最多能删除多少条路而使原本的最短路径不变

思路:数据可以看到比较小,而且还是最短路问题,所以可以用Floyd算法,用完后在判断下如果

1.如果两点之间存在重边还有较大边,则可以删除

2. 两点之间的最短路距离小于原来的最短路距离,就证明这一点发生了更新,这一条边就可以删

3. 两点之间的距离通过一个中转点可以发生更新,那么这一条边就可以删

代码:

#include<map>
#include<stack>
#include<cmath>
#include<queue>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 110
#define inf 9999999
#define ll long long
int e[maxn][maxn];
int a[maxn][maxn];
int main()
{
    int test,q=1;
    scanf("%d",&test);
    while(test--)
    {
        int m,n,i,j,k,t1,t2,t3,ans=0;
        scanf("%d%d",&n,&m);
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                if(i==j)
                    e[i][j]=0;
                else
                    e[i][j]=inf;
            }
        }
        memset(a,0,sizeof(a));
        for(i=1; i<=m; i++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            if(e[t1][t2]!=inf)
                ans++;
            if(e[t1][t2]>t3)
            {
                e[t1][t2]=e[t2][t1]=t3;
            }
        }
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                a[i][j]=e[i][j];
            }
        }
        for(k=1; k<=n; k++)
        {
            for(i=1; i<=n; i++)
            {
                for(j=1; j<=n; j++)
                {
                    if(e[i][j]>e[i][k]+e[k][j])
                        e[i][j]=e[i][k]+e[k][j];
                }
            }
        }
        for(i=1; i<=n; i++)
        {
            for(j=i+1; j<=n; j++)
            {
                for(k=1; k<=n; k++)
                {
                    if(e[i][j]<a[i][j]&&a[i][j]!=inf&&i!=j&&k!=j&&i!=k)
                    {
                        ans++;
                        break;
                    }
                    if(e[i][j]==e[i][k]+e[k][j]&&a[i][j]!=inf&&i!=j&&k!=j&&i!=k)
                    {
                        ans++;
                        break;
                    }
                }
            }
        }
        printf("Case %d: %d\n",q++,ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lee371042/article/details/81091719