17.反片语(Uva156)

输入一些单词,找出所有满足如下条件的单词:

该单词不能通过字母重排,得到输入文本中的另外一个单词。

在判断是否满足条件时,不区分大小写,但输出保留输入中的大小写,按字典序进行排列(所有大写字母在小写字母的前面)

样例输入:

ladder came tape soon leader acme RIDE lone Dreis peat

ScALE orb eye Rides dealer NotE derail LaCeS drIed

noel dire Disk mace Rob dires

样例输出:

Disk
NotE
derail
drIed
eye
ladder
soon

解决:

#include<iostream>
#include<string>
#include<cctype>
#include<vector>
#include<map> // 映射
#include<algorithm>
using namespace std;
map<string, int>cnt;
vector<string>words;

string repr(const string & s)             
{
	string ans = s;
	for (int i = 0; i<ans.length(); i++)
		ans[i] = tolower(ans[i]);
	sort(ans.begin(), ans.end()); 
	return ans;
}
int main()
{
	int n = 0;
	string s;
	while (cin >> s) {
		if (s[0] == '#')break;
		words.push_back(s);    
		string r = repr(s);             
		if (!cnt.count(r))cnt[r] = 0;        
		cnt[r]++;                              
	vector<string>ans;
	for (int i = 0; i<words.size(); i++)
		if (cnt[repr(words[i])] == 1)ans.push_back(words[i]);
		// 仅仅出现一次
	sort(ans.begin(), ans.end());
	for (int i = 0; i<ans.size(); i++)cout << ans[i] << endl;

	return 0;
}

猜你喜欢

转载自blog.csdn.net/W_LAILAI/article/details/84899265