算法习题 反片语 UVa156 及C++STL之map回顾

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_43269048/article/details/99701491

题目跳转链接UVa156
题目描述:

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different
orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this
attribute, no matter how you rearrange their letters, you cannot form another word. Such words are
called ananagrams, an example is QUIZ.
Obviously such definitions depend on the domain within which we are working; you might think
that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible
domain would be the entire English language, but this could lead to some problems. One could restrict
the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the
same domain) but NOTE is not since it can produce TONE.
Write a program that will read in the dictionary of a restricted domain and determine the relative
ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be
“rearranged” at all. The dictionary will contain no more than 1000 words.
Input
Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any
number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken
across lines. Spaces may appear freely around words, and at least one space separates multiple words
on the same line. Note that words that contain the same letters but of differing case are considered to
be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line
consisting of a single ‘#’.
Output
Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram
in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always
be at least one relative ananagram.
Sample Input
ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries
Sample Output
Disk
NotE
derail
drIed
eye
ladder
soon

输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排,得到输入文本中的另外一个单词。再判断是否满足条件时,字母不分大小写,但在输出时应保留输入中的大小写,按字典序进行排序(所有大写字母在所有小写字母的前面)
分析:我的第一想法是先将每个单词标准化,即都变成大写或者小写,然后再进行排序。可以使用set的去重特性和自动排序特性,但是考虑到需要输出的不是全部变为大写或者小写的单词而是原单词,在这里我们使用map更为简单。
代码

#include <iostream>
#include <cstdio>
#include <set>
#include <sstream>
#include <string>
#include <typeinfo>
#include <algorithm>
#include <vector>
#include <map>
#include <cctype> 
using namespace std;

map<string,int> cnt;
vector<string> words;

//将单词s标准化
string repr(const string s){
	string anss=s;
	for(int i=0;i<anss.length();i++)
		anss[i]=tolower(anss[i]);
	sort(anss.begin(),anss.end());
	return anss;
} 
int main()
{
	string s;
	while(cin>>s){
		if(s[0]=='#')break;
		words.push_back(s);
		string r=repr(s);
		if(!cnt.count(r)) cnt[r]=0;
		cnt[r]++;
	}
	vector<string> ans;
	for(int i=0;i<words.size();i++)
		if(cnt[repr(words[i])]==1) ans.push_back(words[i]);
		sort(ans.begin(),ans.end());
	for(int i=0;i<ans.size();i++)
	cout<<ans[i]<<"\n";
	return 0;
} 

map知识点回顾:
map就是简单的键值对,即映射关系。因为重载了[ ]运算符,map像是数组的高级版。例如可以用一个map<string,int> month_name来表示”月份名字到月份编号”的映射,然后用month_name[“July”]=7这样的方式来赋值。

猜你喜欢

转载自blog.csdn.net/qq_43269048/article/details/99701491