UVA-156(Ananagrams)

problem describution

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ. Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE. Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.

Output

Outputwillconsistofaseriesoflines. Eachlinewillconsistofasinglewordthatisarelativeananagram intheinputdictionary. Wordsmustbeoutputinlexicographic(case-sensitive)order. Therewillalways be at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIed
noel dire Disk mace Rob dries
#

Sample Output

Disk
NotE
derail
drIed
eye
ladder
soon

题目大意

输入一系列的包含空格的字母,相连的字母为一个单词,输出“不重复”的单词,这里的不重复有特殊的规则:
如果两个单词由相同的字母组成,那么就是重复的,不分大小写。
输入由#结束对于每一个样例按照字典顺序输出不重复的单词

解题思路

这里需要利用map的下标访问的特点。首先对输入的每一个单词转化为小写再排序,这个时候如果两个单词一样那么就是“重复”…具体的不太好解释我用了两种方式解,大同小异

AC代码

#include<sstream>
#include<string>
#include<algorithm>
#include<iostream>
#include<vector>
#include<map>
#include<cstring>
using namespace std;
int main()
{
    string l,word;
    map<string,pair<string,int> > node;
    map<string,pair<string,int> >::iterator it;
    while(getline(cin,l)&&l!="#")
    {
        stringstream line(l);
        while(line>>word)
        {
            string a=word;
            transform(a.begin(),a.end(),a.begin(),::tolower);
            sort(a.begin(),a.end());//对单词里的数字进行排序

            node[a].first=word;
            node[a].second++;
        }
    }
    it=node.begin();
    vector<string> ans;
    vector<string>::iterator w;
    while(it!=node.end())
    {
        if(it->second.second==1)
        {
            ans.push_back(it->second.first);
        }
        it++;
    }
    sort(ans.begin(),ans.end());
    while(!ans.empty())
    {
        cout<<ans.front()<<endl;
        w=ans.begin();
        ans.erase(w);
    }
}

AC代码

这个代码的注释部分是另一种遍历方式

#include<sstream>
#include<string>
#include<algorithm>
#include<iostream>
#include<vector>
#include<map>
using namespace std;
string tolower_(string &s)
{
    string t=s;
    for(int i=0;i<s.size();i++)
    {
        t[i]=tolower(t[i]);
    }
    sort(t.begin(),t.end());
    return t;
}
int main()
{
    string l,word;
    map<string,int> node;
    map<string,int>::iterator it;
    vector<string> primary;
    while(getline(cin,l)&&l!="#")
    {
        stringstream line(l);
        while(line>>word)
        {
            primary.push_back(word);
            node[tolower_(word)]++;
        }
    }
    it=node.begin();
    vector<string> ans;
    /*vector<string>::iterator w;
    w=primary.begin();
    while(w!=primary.end())
    {
        if(node[tolower_(*w)]==1)
        {
            ans.push_back(*w);
        }
        w++;
    }*/
    for(int i=0;i<primary.size();i++)
    {
        if(node[tolower_(primary[i])]==1)
            ans.push_back(primary[i]);
    }
    sort(ans.begin(),ans.end());
    /*w=ans.begin();
    while(!ans.empty())
    {
        cout<<ans.front()<<endl;
        w=ans.begin();
        ans.erase(w);
    }*/
    for(int i=0;i<ans.size();i++)//用下标的形式遍历
        cout<<ans[i]<<endl;
}

猜你喜欢

转载自blog.csdn.net/qq_43984169/article/details/88246717
今日推荐