最长对称子串

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?,最长对称子串为s PAT&TAP s,于是你应该输出11。

输入格式:

输入在一行中给出长度不超过1000的非空字符串。

输出格式:

在一行中输出最长对称子串的长度。

输入样例:

Is PAT&TAP symmetric?

输出样例:

11
#include<stdio.h>
#include<string.h>
char str[1010];
int main()
{
    int i,j,bg,ed,l;
    gets(str);
    l=strlen(str);
    for(i=l;i>=2;i--)
    {
        for(j=0;j+i<l;j++)
        {
            for(bg=j,ed=j+i;bg<=ed;bg++,ed--)
            {
                if(str[bg]!=str[ed])
                    break;
            }
            if(bg>ed)
                break;
        }
        if(j+i<l)
            break;
    }
    if(i>=2)
    printf("%d",i+1);
    else
        printf("1");
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/shengge-777/p/10398951.html
今日推荐