POJ3617字典序最小问题

Best Cow Line
Time Limit: 1000MS         Memory Limit: 65536K
Total Submissions: 15444         Accepted: 4363
Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B
Sample Output

ABCBCD


题意:

给定长度为N的字符串S,要构造长度为N的字符串T,起初T是空串,反复从S的头部或者尾部删除一个字符,加到T的尾部。目标是构造字典序尽可能小的T。

解题思路:

可以使用贪心,每次都取字符串S头尾中字典序较小的那个加到字符串T的尾部。但会遇到这种情况,S的首尾字字符相同,这时为了能够尽早使用到较小的字符,就要比较下一个字符的大小,下一个字符也有可能相同,这点要注意到。

#include<stdio.h>
int n;
char s[2005];

void solve()
{
    int left = 0;
    int right = n-1;
    while(left<=right)
    {
        bool leftMin = false;
        for(int i=0;i<=n/2;i++)  //这里实现了如果首尾相同则比较下一位大小,这个办法很实用
        {
            if(s[left+i]<s[right-i])
            {
                leftMin = true;
                break;
            }
            if(s[left+i]>s[right-i])
            {
                leftMin = false;
                break;
            }
        }
        if(leftMin)
            printf("%c",s[left++]);
        else
            printf("%c",s[right--]);
    }
}

int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        getchar();
        scanf("%c",&s[i]);
    }
    solve();
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41706331/article/details/86655195