杭电OJ Problem-1010

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output

For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
2 4 7
S..D
....
3 5 8
S..X.
.X...
...XD
4 4 14
S...
....
....
...D
0 0 0

Sample Output

NO
YES
YES
YES
YES

Reference Code

#include <bits/stdc++.h>
using namespace std;
int N,M,T,si,sj,di,dj;
char maze[10][10];
bool vis[10][10],flag;
bool check(int i,int j){
    return i>=0&&i<N&&j>=0&&j<M&&!vis[i][j];
}
void dfs(int i,int j,int t){
	if(maze[i][j]=='D'){
		if(t==T) flag=true;
		return;
	}
	if(flag||t>=T) return;
	vis[i][j]=true;
	if (maze[i][j]!='X'){
        if(check(i-1,j)) dfs(i-1,j,t+1);
        if(check(i,j-1)) dfs(i,j-1,t+1);
        if(check(i+1,j)) dfs(i+1,j,t+1);
        if(check(i,j+1)) dfs(i,j+1,t+1);
	}
	vis[i][j]=false;
}
int main(){
	while(scanf("%d%d%d",&N,&M,&T)&&N){
		flag=false;
		for(int i=0;i<N;i++){
            scanf("%s",maze[i]);
			for(int j=0;j<M;j++){
                vis[i][j]=false;
				if(maze[i][j]=='S') si=i,sj=j;
				if(maze[i][j]=='D') di=i,dj=j;
			}
		}
		if(!((di+dj-si-sj-T)&1)) dfs(si,sj,0);
		printf(flag?"YES\n":"NO\n");
	}
}

Tips

1.迷宫问题的变种,注意到要在给定的时间点(而不是给定时间内!!!)到达目的地。
2.正常搜索会超时,需要借助奇偶性来剪枝,详见代码。
3.注意到这一题中有些点可能会考虑多次,所以在dfs()中要多一步vis[i][j]=false的操作。

猜你喜欢

转载自blog.csdn.net/qq_43549984/article/details/86618523