杭电OJ Problem-1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.
在这里插入图片描述

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Reference Code

#include<bits/stdc++.h>
const int maxn=20+3;
int n,cnt=1;
int nums[maxn];
bool vis[maxn];
bool is_prime(int n){
    for (int i=2;i*i<=n;i++)
        if (n%i==0) return false;
    return true;
}
void dfs(int p){
    if (p==n){
        if (is_prime(nums[p]+nums[1])){
            for (int i=1;i<=n;i++){
                printf("%d",nums[i]);
                printf(i<n?" ":"\n");
            }
        }
        return;
    }
    for (int i=2;i<=n;i++){
        if (is_prime(nums[p]+i)&&!vis[i]){
            vis[i]=true;
            nums[p+1]=i;
            dfs(p+1);
            vis[i]=false;
        }
    }
}
int main(){
    nums[1]=1;
    while (~scanf("%d",&n)){
        printf("Case %d:\n",cnt++);
        if (!(n&1)) dfs(1);
        printf("\n");
    }
    return 0;
}

Tips

1.经典的水题,大部分运行时间用在输出上,深搜加剪枝即可,详见代码。

猜你喜欢

转载自blog.csdn.net/qq_43549984/article/details/86647310
今日推荐