PAT Advanced1099 Build A Binary Search Tree(二叉查找树 BST)

版权声明:个人学习笔记记录 https://blog.csdn.net/Ratina/article/details/86610568

链接:PAT Advanced1099

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42



题意:
二叉树有N个结点(结点编号为0 ~ N-1),给出每个结点的左右孩子的编号(不存在用-1表示)。接着给出一个N个整数的序列,需要把这N个整数填入二叉树的结点中,使得二叉树变成一棵二叉查找树。输出这棵二叉查找树的层序遍历序列。


分析:
利用BST中序遍历序列有序(从小到大)的特性,通过中序遍历的过程将N个整数填入。


以下代码:

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=110;
struct node
{
	int data;
	int Left;
	int Right;
}Node[maxn];
int N,input[maxn],index=0;
void inorder(int root)         //中序遍历的过程中填入整数
{
	if(root==-1)
		return;
	inorder(Node[root].Left);
	Node[root].data=input[index++];
	inorder(Node[root].Right);
}
void levelorder(int root)      //层序遍历并打印
{
	queue<int> q;
	q.push(root);
	while(!q.empty())
	{
		int now=q.front();
		q.pop();
		if(now!=root)
			printf(" ");
		printf("%d",Node[now].data);
		if(Node[now].Left!=-1)
			q.push(Node[now].Left);
		if(Node[now].Right!=-1)
			q.push(Node[now].Right);
	}
}
int main()
{	
	scanf("%d",&N);
	for(int i=0;i<N;i++)
		scanf("%d %d",&Node[i].Left,&Node[i].Right);
	for(int i=0;i<N;i++)
		scanf("%d",&input[i]);
	sort(input,input+N);    //先将输入从小到大排序
	inorder(0);
	levelorder(0);
	return 0;

猜你喜欢

转载自blog.csdn.net/Ratina/article/details/86610568