D - Primes

版权声明:叶小小 https://blog.csdn.net/dy416524/article/details/86471458

Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes. 

Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000. 

The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no". 

Sample Input

1
2
3
4
5
17
0

Sample Output

1: no
2: no
3: yes
4: no
5: yes
6: yes

欧拉筛做的开始一直wa。发现bool数组小了。

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
bool vis[20001]={false};
int susu[6000],x;
void oula(int n)
{
    for(int i=2;i<=n;i++)
    {
        if(!vis[i]) susu[x++]=i;
        for(int j=0;j<x;j++)
        {
            if(i*susu[j]>n) break;
            vis[i*susu[j]]=true;
            if(i%susu[j]==0) break;
        }
    }
}
int main()
{
    oula(20000);
    int cnt=0,n;
    while(1)
    {
        cnt++;
        scanf("%d",&n);
        if(n<=0) break;
        int flag=0;
        if(n==1||n==2)
        {
            printf("%d: no\n",cnt);
            continue;
        }
        else
        {
            for(int i=0;i<x;i++)
            {
                if(susu[i]==n)
                {
                    printf("%d: yes\n",cnt);
                    flag=1;
                    break;
                }
                if(susu[i]>n) break;
            }
        }
        if(flag==0) printf("%d: no\n",cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/dy416524/article/details/86471458