hdu_problem_2020_绝对值排序

/*
*
*Problem Description
*输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。
*
*
*Input
*输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。
*
*
*Output
*对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。
*
*
*Sample Input
*3 3 -4 2
*4 0 1 2 -3
*0
*
*
*Sample Output
*-4 3 2
*-3 2 1 0
*
*
*Author
*lcy
*
*
*Source
*C语言程序设计练习(三)
*
*
*Recommend
*lcy
*
*/
#include<iostream>
using namespace std;
int a[100];
int abs(int n) {
 if (n < 0) return -n;
 return n;
}
int main() {
 int n, temp;
 while (cin >> n) {
  if (n == 0) break;
  for (int i = 0; i < n; i++) {
   cin >> a[i];
  }
  // 冒泡排序
  for (int i = 0; i < n; i++) {
   for (int j = i; j < n; j++) {
    if (abs(a[j]) > abs(a[i])) swap(a[j], a[i]);
   }
  }
  cout << a[0];
  for (int i = 1; i < n; i++) {
   cout << " " << a[i];
  }
  cout << endl;
 }
 system("pause");
 return 0;
}

猜你喜欢

转载自blog.csdn.net/CoderMaximum/article/details/86550645